@babel/runtime • 7.29.10 babel's modular runtime helpers INDIRECT 0 1791366653 @types/body-parser • 1.19.6 TypeScript definitions for body-parser INDIRECT 3 1749262526 @types/connect • 3.4.38 TypeScript definitions for connect INDIRECT 2 1699318654 @types/cors • 2.8.19 TypeScript definitions for cors DIRECT 2 1749262586 @types/express-serve-static-core • 4.19.9 TypeScript definitions for express-serve-static-core INDIRECT 5 1783444527 @types/express • 4.17.25 TypeScript definitions for express DIRECT 12 1761597367 @types/graphql • 0.12.7 TypeScript definitions for graphql DIRECT 0 1522176795 @types/http-errors • 2.0.5 TypeScript definitions for http-errors INDIRECT 0 1749262653 @types/mime • 1.3.5 TypeScript definitions for mime INDIRECT 0 1699388774 @types/node • 26.6.5 TypeScript definitions for node INDIRECT 1 1791571607 @types/qs • 6.15.1 TypeScript definitions for qs INDIRECT 0 1778111161 @types/range-parser • 1.2.7 TypeScript definitions for range-parser INDIRECT 0 1699364722 @types/send • 0.17.6 TypeScript definitions for send INDIRECT 3 1761280662 @types/send • 1.2.1 TypeScript definitions for send INDIRECT 2 1761280656 @types/serve-static • 1.15.10 TypeScript definitions for serve-static INDIRECT 5 1761280256 @types/zen-observable • 0.5.4 TypeScript definitions for zen-observable DIRECT 0 1529112983 @wry/equality • 0.1.11 Structural equality checking for JavaScript values INDIRECT 1 1585510970 accepts • 1.3.8 Higher-level content negotiation INDIRECT 3 1643845928 apollo-cache-control • 0.1.1 A GraphQL extension for cache control INDIRECT 5 1523924208 apollo-link • 1.2.14 Flexible, lightweight transport layer for GraphQL INDIRECT 7 1586458726 apollo-server-core • 1.4.0 Core engine for Apollo GraphQL server INDIRECT 7 1531507619 apollo-server-express • 1.4.0 Production-ready Node.js GraphQL server for Express and Connect DIRECT 9 1531507630 apollo-server-lambda • 1.3.2 Production-ready Node.js GraphQL server for AWS Lambda DIRECT 9 1513699387 apollo-server-module-graphiql • 1.4.0 GraphiQL renderer for Apollo GraphQL Server INDIRECT 0 1531507618 apollo-tracing • 0.1.4 Collect and expose trace data for GraphQL requests INDIRECT 5 1522236128 apollo-upload-server • 4.0.0-alpha.3 Enhances Apollo GraphQL Server for intuitive file uploads via GraphQL mutations. DIRECT 10 1515979128 apollo-utilities • 1.3.4 Utilities for working with GraphQL ASTs INDIRECT 4 1589021700 argparse • 1.0.10 Very powerful CLI arguments parser. Native port of argparse - python's options parsing library INDIRECT 1 1518704641 array-flatten • 1.1.1 Flatten an array of nested arrays into a single flat array INDIRECT 0 1436478175 async-function • 1.0.0 A function that returns the normally hidden `AsyncFunction` constructor INDIRECT 0 1737602154 async-generator-function • 1.0.0 A function that returns the normally hidden `AsyncGeneratorFunction` constructor INDIRECT 0 1739558117 available-typed-arrays • 1.0.7 Returns an array of Typed Array names that are available in the current environment INDIRECT 1 1708386870 aws-lambda • 0.1.2 Deploy AWS Lambda functions from command line using a .json config file. DIRECT 49 1481013330 backo2 • 1.0.2 simple backoff based on segmentio/backo INDIRECT 0 1416723058 balanced-match • 1.0.2 Match balanced character pairs, like "{" and "}" INDIRECT 0 1617713469 base64-js • 1.5.1 Base64 encoding/decoding in pure JS INDIRECT 0 1605123228 body-parser-graphql • 1.0.0 GraphQL server middleware to support application/graphql requests DIRECT 44 1514800636 body-parser • 1.20.8 Node.js body parsing middleware INDIRECT 43 1788863534 brace-expansion • 1.1.21 Brace expansion as known from sh/bash INDIRECT 2 1789423168 buffer-from • 1.1.2 A [ponyfill](https://ponyfill.com) for `Buffer.from`, uses native implementation if available. INDIRECT 0 1627578333 buffer • 4.9.2 Node.js Buffer API, for the browser INDIRECT 3 1573256836 bytes • 3.1.2 Utility to parse a string bytes to bytes and vice-versa INDIRECT 0 1643346157 call-bind-apply-helpers • 1.0.2 Helper functions around Function call/apply/bind, for use in `call-bind` INDIRECT 2 1739388296 call-bind • 1.0.9 Robustly `.call.bind()` a function INDIRECT 18 1775749088 call-bound • 1.0.4 Robust call-bound JavaScript intrinsics, using `call-bind` and `get-intrinsic`. INDIRECT 15 1741024203 commander • 2.20.3 the complete solution for node.js command-line programs INDIRECT 0 1570772424 concat-map • 0.0.1 concatenative mapdashery INDIRECT 0 1391051195 content-disposition • 0.5.4 Create and parse Content-Disposition header INDIRECT 1 1639176934 content-type • 1.0.5 Create and parse HTTP Content-Type header INDIRECT 0 1675020359 cookie-signature • 1.0.7 Sign and unsign cookies INDIRECT 0 1681343950 cookie • 0.7.2 HTTP server cookie parsing and serialization INDIRECT 0 1728272488 core-js • 2.6.12 Standard library INDIRECT 0 1606327727 core-util-is • 1.0.3 The `util.is*` functions introduced in Node v0.12. INDIRECT 0 1630420536 cors • 2.8.6 Node.js CORS middleware DIRECT 2 1769092890 cross-fetch • 2.2.2 Universal WHATWG Fetch API for Node, Browsers and React Native INDIRECT 2 1530274588 debug • 2.6.9 small debugging utility INDIRECT 1 1506087155 define-data-property • 1.1.4 Define a data property on an object. Will fall back to assignment in an engine without descriptors. INDIRECT 3 1707843362 depd • 2.0.0 Deprecate all the things INDIRECT 0 1540576375 deprecated-decorator • 0.1.6 A simple decorator for deprecated methods and properties. INDIRECT 0 1460445444 destroy • 1.2.0 destroy a stream if possible INDIRECT 0 1647802992 dunder-proto • 1.0.1 If available, the `Object.prototype.__proto__` accessor and mutator, call-bound INDIRECT 4 1734401567 ee-first • 1.1.1 return the first event in a set of ee/event pairs INDIRECT 0 1432581508 encodeurl • 2.0.0 Encode a URL to a percent-encoded form, excluding already-encoded sequences INDIRECT 0 1711670622 es-define-property • 1.0.1 `Object.defineProperty`, but not IE 8's broken one. INDIRECT 0 1733508962 es-errors • 1.3.0 A simple cache for a few of the JS Error constructors. INDIRECT 0 1707120351 es-object-atoms • 1.1.2 ES Object-related atoms: Object, ToObject, RequireObjectCoercible INDIRECT 1 1779460803 escape-html • 1.0.3 Escape string for use in HTML INDIRECT 0 1441082842 etag • 1.8.1 Create simple HTTP ETags INDIRECT 0 1505270624 eventemitter3 • 3.1.2 EventEmitter3 focuses on performance while maintaining a Node.js AND browser compatible interface. INDIRECT 0 1556600623 events • 1.1.1 Node's event emitter for all engines. INDIRECT 0 1466611760 express • 4.22.3 Fast, unopinionated, minimalist web framework DIRECT 70 1789368398 fast-json-stable-stringify • 2.1.0 deterministic `JSON.stringify()` - a faster version of substack's json-stable-strigify without jsonify INDIRECT 0 1576340277 finalhandler • 1.3.2 Node.js final http responder INDIRECT 9 1764604790 for-each • 0.3.5 A better forEach INDIRECT 1 1739256963 forwarded • 0.2.0 Parse HTTP X-Forwarded-For header INDIRECT 0 1622503382 fresh • 0.5.2 HTTP response freshness testing INDIRECT 0 1505365392 function-bind • 1.1.2 Implementation of Function.prototype.bind INDIRECT 0 1697137699 generator-function • 2.0.1 A function that returns the normally hidden `GeneratorFunction` constructor INDIRECT 0 1759256613 get-intrinsic • 1.3.1 Get and robustly cache all JS language-level intrinsics at first require time INDIRECT 14 1759188007 get-proto • 1.0.1 Robustly get the [[Prototype]] of an object INDIRECT 6 1735848482 gopd • 1.2.0 `Object.getOwnPropertyDescriptor`, but accounts for IE's broken implementation. INDIRECT 0 1733329312 graphql-config • 1.1.7 The easiest way to configure your development environment with your GraphQL schema (supported by most tools, editors & IDEs) INDIRECT 16 1515845988 graphql-extensions • 0.0.10 Add extensions to GraphQL servers INDIRECT 4 1522389804 graphql-import • 0.4.5 [](https://circleci.com/gh/graphcool/graphql-import) [](https://badge.fury.io/js/graphql-import) DIRECT 1 1519723194 graphql-request • 1.8.2 [](https://circleci.com/gh/prismagraphql/graphql-request) [](https://badge.fury.io/js/graphql-request) INDIRECT 3 1533886301 graphql-subscriptions • 0.5.8 GraphQL subscriptions for node.js DIRECT 1 1519303399 graphql-tools • 2.24.0 Useful tools to create and manipulate GraphQL schemas. DIRECT 11 1523388158 graphql • 0.12.3 A Query Language and Runtime which can target any service. INDIRECT 1 1513485304 graphql • 0.13.2 A Query Language and Runtime which can target any service. DIRECT 1 1521233988 has-property-descriptors • 1.0.2 Does the environment have full property descriptor support? Handles IE 8's broken defineProperty/gOPD. INDIRECT 1 1707801707 has-symbols • 1.1.0 Determine if the JS environment has Symbol support. Supports spec, or shams. INDIRECT 0 1733157257 has-tostringtag • 1.0.2 Determine if the JS environment has `Symbol.toStringTag` support. Supports spec, or shams. INDIRECT 1 1706823840 hasown • 2.0.4 A robust, ES3 compatible, "has own property" predicate. INDIRECT 1 1779991899 http-errors • 2.0.1 Create HTTP error objects INDIRECT 5 1763665942 iconv-lite • 0.4.24 Convert character encodings in pure javascript. INDIRECT 1 1534969392 ipaddr.js • 1.9.1 A library for manipulating IPv4 and IPv6 addresses in JavaScript. INDIRECT 0 1563330499 is-arguments • 1.2.0 Is this an arguments object? It's a harder question than you think. INDIRECT 17 1734073522 is-callable • 1.2.7 Is this JS value callable? Works with Functions and GeneratorFunctions, despite ES6 @@toStringTag. INDIRECT 0 1663973379 is-generator-function • 1.1.2 Determine if a function is a native generator function. INDIRECT 19 1759257674 is-regex • 1.2.1 Is this value a JS regex? Works cross-realm/iframe, and despite ES6 @@toStringTag INDIRECT 17 1733982247 is-typed-array • 1.1.15 Is this value a JS Typed Array? This module works cross-realm/iframe, does not depend on `instanceof` or mutable properties, and despite ES6 Symbol.toStringTag. INDIRECT 26 1734542407 isarray • 0.0.1 Array#isArray for older browsers INDIRECT 0 1369676435 isarray • 1.0.0 Array#isArray for older browsers INDIRECT 0 1449741907 iterall • 1.1.3 Minimal zero-dependency utilities for using JavaScript Iterables in all environments. INDIRECT 0 1506633497 iterall • 1.3.0 Minimal zero-dependency utilities for using JavaScript Iterables in all environments. INDIRECT 0 1578018635 js-yaml • 3.15.2 YAML 1.2 parser and serializer INDIRECT 3 1787777630 lodash • 4.18.1 Lodash modular utilities. INDIRECT 0 1775077280 math-intrinsics • 1.1.0 ES Math-related intrinsics and helpers, robustly cached. INDIRECT 0 1734587889 media-typer • 0.3.0 Simple RFC 6838 media type parser and formatter INDIRECT 0 1410150744 merge-descriptors • 1.0.3 Merge objects using descriptors INDIRECT 0 1700155732 methods • 1.1.2 HTTP methods that node supports INDIRECT 0 1453085636 mime-db • 1.52.0 Media Type Database INDIRECT 0 1645472511 mime-types • 2.1.35 The ultimate javascript content-type utility. INDIRECT 1 1647108283 mime • 1.6.0 A comprehensive library for mime-type mapping INDIRECT 0 1511571199 ms • 2.0.0 Tiny milisecond conversion utility INDIRECT 0 1494937566 ms • 2.1.3 Tiny millisecond conversion utility INDIRECT 0 1607435675 negotiator • 0.6.3 HTTP content negotiation INDIRECT 0 1642902613 node-fetch • 2.1.2 A light-weight module that brings window.fetch to node.js INDIRECT 0 1522011300 object-assign • 4.1.1 ES2015 `Object.assign()` ponyfill INDIRECT 0 1484580915 object-inspect • 1.13.4 string representations of objects in node and the browser INDIRECT 0 1738718770 object-path • 0.11.8 Access deep object properties using a path INDIRECT 0 1631790037 on-finished • 2.4.1 Execute a callback when a request closes, finishes, or errors INDIRECT 1 1645546248 parseurl • 1.3.3 parse a url with memoization INDIRECT 0 1555388186 path-to-regexp • 0.1.13 Express style path to RegExp utility INDIRECT 0 1774539760 possible-typed-array-names • 1.1.0 A simple list of possible Typed Array names. INDIRECT 0 1738904655 proxy-addr • 2.0.8 Determine address of proxied request INDIRECT 2 1789452765 punycode • 1.3.2 A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms. INDIRECT 0 1413980428 querystring • 0.2.0 Node's querystring module for all engines. INDIRECT 0 1362521623 range-parser • 1.2.1 Range header field string parser INDIRECT 0 1557534457 raw-body • 2.5.3 Get and validate the raw body of a readable stream. INDIRECT 10 1764084228 readable-stream • 1.1.14 Streams3, a user-land copy of the stream library from Node.js v0.11.x INDIRECT 4 1460563294 safe-buffer • 5.2.1 Safer Node.js Buffer API INDIRECT 0 1589128650 safe-regex-test • 1.1.0 Give a regex, get a robust predicate function that tests it against a string. INDIRECT 18 1734029347 safer-buffer • 2.1.2 Modern Buffer API polyfill without footguns INDIRECT 0 1523184162 send • 0.19.2 Better streaming static file server with Range and conditional-GET support INDIRECT 18 1765826944 serve-static • 1.16.3 Serve static files INDIRECT 20 1765825976 set-function-length • 1.2.2 Set a function's length property INDIRECT 17 1710006059 side-channel-list • 1.0.1 Store information about any JS value in a side channel, using a linked list INDIRECT 2 1775667313 side-channel-map • 1.0.1 Store information about any JS value in a side channel, using a Map INDIRECT 17 1733892798 side-channel-weakmap • 1.0.2 Store information about any JS value in a side channel. Uses WeakMap if available. INDIRECT 18 1733895551 side-channel • 1.1.1 Store information about any JS value in a side channel. Uses WeakMap if available. INDIRECT 20 1780950887 source-map-support • 0.5.21 Fixes stack traces for files with source maps INDIRECT 2 1637319777 statuses • 2.0.2 HTTP status utility INDIRECT 0 1749239761 string_decoder • 0.10.31 The string_decoder module from Node core INDIRECT 0 1408767919 subscriptions-transport-ws • 0.9.19 A websocket transport for GraphQL subscriptions DIRECT 5 1623182395 symbol-observable • 1.2.0 Symbol.observable ponyfill INDIRECT 0 1516988510 toidentifier • 1.0.1 Convert a string of words to a JavaScript identifier INDIRECT 0 1636928349 ts-invariant • 0.4.4 TypeScript implementation of invariant(condition, message) INDIRECT 1 1559922808 type-is • 1.6.18 Infer the content-type of a request. INDIRECT 3 1556287189 undici-types • 8.9.0 A stand-alone types package for Undici INDIRECT 0 1784896376 unpipe • 1.0.0 Unpipe a stream from all destinations INDIRECT 0 1434313819 url • 0.10.3 The core `url` packaged standalone for use with Browserify. INDIRECT 2 1425062241 util • 0.12.5 Node.js's util module for all engines INDIRECT 32 1665951987 utils-merge • 1.0.1 merge() utility function INDIRECT 0 1505866719 uuid • 3.4.0 RFC4122 (v1, v4, and v5) UUIDs INDIRECT 0 1579208738 uuid • 8.0.0 RFC4122 (v1, v4, and v5) UUIDs INDIRECT 0 1588192946 vary • 1.1.2 Manipulate the HTTP Vary header INDIRECT 0 1506217631 whatwg-fetch • 2.0.4 A window.fetch polyfill. INDIRECT 0 1522408997 which-typed-array • 1.1.24 Which kind of Typed Array is this JavaScript value? Works cross-realm, without `instanceof`, and despite Symbol.toStringTag. INDIRECT 25 1789768351 ws • 7.5.13 Simple to use, blazing fast and thoroughly tested websocket client and server for Node.js INDIRECT 0 1784306758 xml2js • 0.6.2 Simple XML to JavaScript object converter. INDIRECT 2 1690366989 xmlbuilder • 11.0.1 An XML builder for node.js INDIRECT 0 1553287553 zen-observable-ts • 0.8.21 An Implementation of ES Observables in Typescript INDIRECT 2 1586458723 zen-observable • 0.8.15 An Implementation of ES Observables INDIRECT 0 1574188483