licenses.dev

@arkecosystem/crypto v3.13.0

Crypto utilities for the ARK Blockchain

Published on

Licenses

Learn more about license information.

Package Licenses

MIT

Dependency Licenses

MIT91
PackageRelationDependenciesPublished
@arkecosystem/crypto-identities • 1.2.0Standalone version of identity interactions for the ARK Blockchain. Developed for TypeScript.DIRECT56
@arkecosystem/crypto-networks • 2.0.2Network configurations for the ARK Blockchain. Developed for TypeScript.DIRECT0
@arkecosystem/utils • 1.3.1Performance oriented implementations of commonly used functions in TypeScript.DIRECT6
@types/node • 10.12.18TypeScript definitions for Node.jsINDIRECT0
@types/node • 11.11.6TypeScript definitions for Node.jsINDIRECT0
ajv-keywords • 3.4.1Custom JSON-Schema keywords for Ajv validatorDIRECT0
ajv • 6.12.6Another JSON Schema ValidatorDIRECT5
async-function • 1.0.0A function that returns the normally hidden `AsyncFunction` constructorINDIRECT0
async-generator-function • 1.0.0A function that returns the normally hidden `AsyncGeneratorFunction` constructorINDIRECT0
available-typed-arrays • 1.0.7Returns an array of Typed Array names that are available in the current environmentINDIRECT1
base-x • 3.0.11Fast base encoding / decoding of any given alphabetINDIRECT1
bcrypto • 5.5.2JS crypto libraryDIRECT2
bindings • 1.5.0Helper module for loading your native module's .node fileINDIRECT1
bip32 • 2.0.6A BIP32 compatible libraryDIRECT63
bn.js • 4.12.5Big number implementation in pure javascriptINDIRECT0
brorand • 1.1.0Random number generator for browsers and node.jsINDIRECT0
browserify-aes • 1.2.0aes, for browserifyDIRECT47
bs58 • 4.0.1Base 58 encoding / decodingINDIRECT2
bs58check • 2.1.2A straightforward implementation of base58-check encodingINDIRECT47
bsert • 0.0.13Minimal assert with type checkingINDIRECT0
bstring • 0.3.9String encodings for javascriptDIRECT3
buffer-xor • 1.0.3A simple module for bitwise-xor on buffersINDIRECT0
buffer-xor • 2.0.2A simple module for bitwise-xor on buffersDIRECT1
bufio • 1.0.7Buffer and serialization utilities for javascriptINDIRECT0
builtin-modules • 3.3.0List of the Node.js builtin modulesDIRECT0
call-bind-apply-helpers • 1.0.2Helper functions around Function call/apply/bind, for use in `call-bind`INDIRECT2
call-bind • 1.0.9Robustly `.call.bind()` a functionINDIRECT18
call-bound • 1.0.4Robust call-bound JavaScript intrinsics, using `call-bind` and `get-intrinsic`.INDIRECT15
cipher-base • 1.0.7abstract base class for crypto-streamsINDIRECT32
core-util-is • 1.0.3The `util.is*` functions introduced in Node v0.12.INDIRECT0
create-hash • 1.2.0create hashes for browserifyINDIRECT44
create-hmac • 1.1.7node style hmacs in the browserINDIRECT45
dayjs • 1.11.102KB immutable date time library alternative to Moment.js with the same modern API DIRECT0
deepmerge • 4.3.1A library for deep (recursive) merging of Javascript objectsDIRECT0
define-data-property • 1.1.4Define a data property on an object. Will fall back to assignment in an engine without descriptors.INDIRECT3
dunder-proto • 1.0.1If available, the `Object.prototype.__proto__` accessor and mutator, call-boundINDIRECT4
elliptic • 6.6.1EC cryptographyINDIRECT7
es-define-property • 1.0.1`Object.defineProperty`, but not IE 8's broken one.INDIRECT0
es-errors • 1.3.0A simple cache for a few of the JS Error constructors.INDIRECT0
es-object-atoms • 1.1.2ES Object-related atoms: Object, ToObject, RequireObjectCoercibleINDIRECT1
evp_bytestokey • 1.0.3The insecure key derivation algorithm from OpenSSLINDIRECT41
fast-copy • 2.2.0A blazing fast deep object copierINDIRECT0
fast-deep-equal • 3.1.3Fast deep equalINDIRECT0
fast-json-stable-stringify • 2.1.0deterministic `JSON.stringify()` - a faster version of substack's json-stable-strigify without jsonifyINDIRECT0
fast-memoize • 2.5.2Fastest memoization lib that supports N argumentsDIRECT0
fast-sort • 2.2.0Fast and powerful array sorting. Sort by any property in any direction with easy to read syntax.INDIRECT0
file-uri-to-path • 1.0.0Convert a file: URI to a file pathINDIRECT0
for-each • 0.3.5A better forEachINDIRECT1
function-bind • 1.1.2Implementation of Function.prototype.bindINDIRECT0
generator-function • 2.0.1A function that returns the normally hidden `GeneratorFunction` constructorINDIRECT0
get-intrinsic • 1.3.1Get and robustly cache all JS language-level intrinsics at first require timeINDIRECT14
get-proto • 1.0.1Robustly get the [[Prototype]] of an objectINDIRECT6
gopd • 1.2.0`Object.getOwnPropertyDescriptor`, but accounts for IE's broken implementation.INDIRECT0
has-property-descriptors • 1.0.2Does the environment have full property descriptor support? Handles IE 8's broken defineProperty/gOPD.INDIRECT1
has-symbols • 1.1.0Determine if the JS environment has Symbol support. Supports spec, or shams.INDIRECT0
has-tostringtag • 1.0.2Determine if the JS environment has `Symbol.toStringTag` support. Supports spec, or shams.INDIRECT1
hash-base • 3.1.2abstract base class for hash-streamsINDIRECT39
hash.js • 1.1.7Various hash functions that could be run by both browser and nodeINDIRECT2
hasown • 2.0.4A robust, ES3 compatible, "has own property" predicate.INDIRECT1
hmac-drbg • 1.0.1Deterministic random bit generator (hmac)INDIRECT4
ipaddr.js • 2.1.0A library for manipulating IPv4 and IPv6 addresses in JavaScript.DIRECT0
is-callable • 1.2.7Is this JS value callable? Works with Functions and GeneratorFunctions, despite ES6 @@toStringTag.INDIRECT0
is-typed-array • 1.1.15Is this value a JS Typed Array? This module works cross-realm/iframe, does not depend on `instanceof` or mutable properties, and despite ES6 Symbol.toStringTag.INDIRECT26
isarray • 1.0.0Array#isArray for older browsersINDIRECT0
isarray • 2.0.5Array#isArray for older browsersINDIRECT0
json-schema-traverse • 0.4.1Traverse JSON Schema passing each schema object to callbackINDIRECT0
loady • 0.0.5dynamic loader for node.jsINDIRECT0
lodash.get • 4.4.2The lodash method `_.get` exported as a module.DIRECT0
lodash.set • 4.3.2The lodash method `_.set` exported as a module.DIRECT0
math-intrinsics • 1.1.0ES Math-related intrinsics and helpers, robustly cached.INDIRECT0
md5.js • 1.3.5node style md5 on pure JavaScriptINDIRECT40
minimalistic-crypto-utils • 1.0.1Minimalistic tools for JS crypto modulesINDIRECT0
nan • 2.29.0Native Abstractions for Node.js: C++ header for Node 0.8 -> 26 compatibilityINDIRECT0
pbkdf2 • 3.1.6This library provides the functionality of PBKDF2 with the ability to use any supported hashing algorithm returned from crypto.getHashes()INDIRECT46
possible-typed-array-names • 1.1.0A simple list of possible Typed Array names.INDIRECT0
process-nextick-args • 2.0.1process.nextTick but always with argsINDIRECT0
punycode • 2.3.1A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms.INDIRECT0
randombytes • 2.1.0random bytes from browserify stand aloneINDIRECT1
readable-stream • 2.3.8Streams3, a user-land copy of the stream library from Node.jsINDIRECT7
ripemd160 • 2.0.3Compute ripemd160 of bytes or strings.INDIRECT40
safe-buffer • 5.1.2Safer Node.js Buffer APIINDIRECT0
safe-buffer • 5.2.1Safer Node.js Buffer APIINDIRECT0
set-function-length • 1.2.2Set a function's length propertyINDIRECT17
string_decoder • 1.1.1The string_decoder module from Node coreINDIRECT1
tiny-secp256k1 • 1.1.7A tiny secp256k1 native/JS wrapperINDIRECT56
to-buffer • 1.2.2Pass in a string, array, Buffer, Data View, or Uint8Array, and get a Buffer back.INDIRECT30
typed-array-buffer • 1.0.3Get the ArrayBuffer out of a TypedArray, robustly.INDIRECT27
typeforce • 1.18.0Another biased type checking solution for JavascriptINDIRECT0
util-deprecate • 1.0.2The Node.js `util.deprecate()` function with browser supportINDIRECT0
which-typed-array • 1.1.24Which kind of Typed Array is this JavaScript value? Works cross-realm, without `instanceof`, and despite Symbol.toStringTag.INDIRECT25
wif • 2.0.6Bitcoin Wallet Import Format (WIF) decoding/encoding moduleINDIRECT48
ISC3
PackageRelationDependenciesPublished
bip39 • 3.0.4Bitcoin BIP39: Mnemonic code for generating deterministic keysDIRECT49
inherits • 2.0.4Browser-friendly inheritance fully compatible with standard node.js inherits()INDIRECT0
minimalistic-assert • 1.0.1minimalistic-assert ===INDIRECT0
Apache-2.02
PackageRelationDependenciesPublished
bytebuffer • 5.0.1The swiss army knife for binary data in JavaScript.DIRECT1
long • 3.2.0A Long class for representing a 64-bit two's-complement integer value.INDIRECT0
BSD-3-Clause1
PackageRelationDependenciesPublished
@hapi/bourne • 2.1.0JSON parse with prototype poisoning protectionINDIRECT0
CC0-1.0 OR MIT1
PackageRelationDependenciesPublished
type-fest • 0.17.0A collection of essential TypeScript typesINDIRECT0
BSD-2-Clause1
PackageRelationDependenciesPublished
uri-js • 4.4.1An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.INDIRECT1
BSD-3-Clause AND MIT1
PackageRelationDependenciesPublished
sha.js • 2.4.12Streamable SHA hashes in pure javascriptINDIRECT32
Last updated on

Copy the licenses badge code for the latest version:

[![licenses](https://licenses.dev/b/npm/%40arkecosystem%2Fcrypto)](https://licenses.dev/npm/%40arkecosystem%2Fcrypto)
<a href="https://licenses.dev/npm/%40arkecosystem%2Fcrypto">
  <img src="https://licenses.dev/b/npm/%40arkecosystem%2Fcrypto" alt="licenses" />
</a>

Or the licenses badge code for the 3.13.0 version:

[![licenses](https://licenses.dev/b/npm/%40arkecosystem%2Fcrypto/3.13.0)](https://licenses.dev/npm/%40arkecosystem%2Fcrypto/3.13.0)
<a href="https://licenses.dev/npm/%40arkecosystem%2Fcrypto/3.13.0">
  <img src="https://licenses.dev/b/npm/%40arkecosystem%2Fcrypto/3.13.0" alt="licenses" />
</a>
GitHub