ajv • 6.15.0 Another JSON Schema Validator INDIRECT 5 1776956364 asn1 • 0.2.6 Contains parsers and serializers for ASN.1 (currently BER only) INDIRECT 1 1635986788 assert-plus • 1.0.0 Extra assertions on top of node's assert module INDIRECT 0 1453921418 async-function • 1.0.0 A function that returns the normally hidden `AsyncFunction` constructor INDIRECT 0 1737602154 async-generator-function • 1.0.0 A function that returns the normally hidden `AsyncGeneratorFunction` constructor INDIRECT 0 1739558117 async • 3.2.6 Higher-order functions and common patterns for asynchronous code DIRECT 0 1724109863 asynckit • 0.4.0 Minimal async jobs utility library, with streams support INDIRECT 0 1465928945 aws4 • 1.13.2 Signs and prepares requests using AWS Signature Version 4 INDIRECT 0 1724831030 basic-auth • 2.0.1 node.js basic auth parser INDIRECT 1 1537413962 bitcore-lib-dash • 0.15.3 A pure and powerful JavaScript Dash library. DIRECT 12 1519131771 bitcore-message-dash • 1.0.9 Dash Messages for Bitcore-Dash DIRECT 13 1513645698 bn.js • 2.0.4 Big number implementation in pure javascript INDIRECT 0 1430384255 body-parser • 1.20.8 Node.js body parsing middleware DIRECT 43 1788863534 brorand • 1.1.0 Random number generator for browsers and node.js INDIRECT 0 1487799562 bs58 • 2.0.0 Base 58 encoding / decoding INDIRECT 0 1412325784 bytes • 3.1.2 Utility to parse a string bytes to bytes and vice-versa INDIRECT 0 1643346157 call-bind-apply-helpers • 1.0.2 Helper functions around Function call/apply/bind, for use in `call-bind` INDIRECT 2 1739388296 call-bound • 1.0.4 Robust call-bound JavaScript intrinsics, using `call-bind` and `get-intrinsic`. INDIRECT 15 1741024203 combined-stream • 1.0.8 A stream that emits multiple other streams one after another. INDIRECT 1 1557683385 compressible • 2.0.18 Compressible Content-Type / mime checking INDIRECT 1 1578286209 compression • 1.8.2 Node.js compression middleware DIRECT 10 1789125407 content-type • 1.0.5 Create and parse HTTP Content-Type header INDIRECT 0 1675020359 core-util-is • 1.0.2 The `util.is*` functions introduced in Node v0.12. INDIRECT 0 1447979853 dashdash • 1.14.1 A light, featureful and explicit option parsing library. INDIRECT 1 1479854020 debug • 2.6.9 small debugging utility INDIRECT 1 1506087155 delayed-stream • 1.0.0 Buffers events from a stream until you are ready to handle them. INDIRECT 0 1430431829 depd • 2.0.0 Deprecate all the things INDIRECT 0 1540576375 destroy • 1.2.0 destroy a stream if possible INDIRECT 0 1647802992 dunder-proto • 1.0.1 If available, the `Object.prototype.__proto__` accessor and mutator, call-bound INDIRECT 4 1734401567 ecc-jsbn • 0.1.2 ECC JS code based on JSBN INDIRECT 2 1532879660 ee-first • 1.1.1 return the first event in a set of ee/event pairs INDIRECT 0 1432581508 elliptic • 3.0.3 EC cryptography INDIRECT 6 1425063997 es-define-property • 1.0.1 `Object.defineProperty`, but not IE 8's broken one. INDIRECT 0 1733508962 es-errors • 1.3.0 A simple cache for a few of the JS Error constructors. INDIRECT 0 1707120351 es-object-atoms • 1.1.2 ES Object-related atoms: Object, ToObject, RequireObjectCoercible INDIRECT 1 1779460803 extend • 3.0.2 Port of jQuery.extend for node.js and the browser INDIRECT 0 1532032091 extsprintf • 1.3.0 extended POSIX-style sprintf INDIRECT 0 1425687180 fast-deep-equal • 3.1.3 Fast deep equal INDIRECT 0 1591601248 fast-json-stable-stringify • 2.1.0 deterministic `JSON.stringify()` - a faster version of substack's json-stable-strigify without jsonify INDIRECT 0 1576340277 form-data • 2.3.3 A library to create readable "multipart/form-data" streams. Can be used to submit forms and file uploads to other web applications. INDIRECT 5 1539761182 function-bind • 1.1.2 Implementation of Function.prototype.bind INDIRECT 0 1697137699 generator-function • 2.0.1 A function that returns the normally hidden `GeneratorFunction` constructor INDIRECT 0 1759256613 get-intrinsic • 1.3.1 Get and robustly cache all JS language-level intrinsics at first require time INDIRECT 14 1759188007 get-proto • 1.0.1 Robustly get the [[Prototype]] of an object INDIRECT 6 1735848482 getpass • 0.1.7 getpass for node.js INDIRECT 1 1493163658 gopd • 1.2.0 `Object.getOwnPropertyDescriptor`, but accounts for IE's broken implementation. INDIRECT 0 1733329312 har-validator • 5.1.5 Extremely fast HTTP Archive (HAR) validator using JSON Schema INDIRECT 7 1596084153 has-symbols • 1.1.0 Determine if the JS environment has Symbol support. Supports spec, or shams. INDIRECT 0 1733157257 hash.js • 1.1.7 Various hash functions that could be run by both browser and node INDIRECT 2 1543607403 hasown • 2.0.4 A robust, ES3 compatible, "has own property" predicate. INDIRECT 1 1779991899 http-errors • 2.0.1 Create HTTP error objects INDIRECT 5 1763665942 http-signature • 1.2.0 Reference implementation of Joyent's HTTP Signature scheme. INDIRECT 15 1503689523 iconv-lite • 0.4.24 Convert character encodings in pure javascript. INDIRECT 1 1534969392 is-typedarray • 1.0.0 Detect whether or not an object is a Typed Array INDIRECT 0 1431824619 isstream • 0.1.2 Determine if an object is a Stream INDIRECT 0 1425687315 jsbn • 0.1.1 The jsbn library is a fast, portable implementation of large-number math in pure JavaScript, enabling public-key crypto and other applications on desktop and mobile browsers. INDIRECT 0 1486886596 json-schema-traverse • 0.4.1 Traverse JSON Schema passing each schema object to callback INDIRECT 0 1528620125 jsprim • 1.4.2 utilities for primitive JavaScript types INDIRECT 5 1638199465 lodash • 4.17.1 Lodash modular utilities. DIRECT 0 1479193405 math-intrinsics • 1.1.0 ES Math-related intrinsics and helpers, robustly cached. INDIRECT 0 1734587889 media-typer • 0.3.0 Simple RFC 6838 media type parser and formatter INDIRECT 0 1410150744 mime-db • 1.52.0 Media Type Database INDIRECT 0 1645472511 mime-types • 2.1.35 The ultimate javascript content-type utility. INDIRECT 1 1647108283 morgan • 1.12.1 HTTP request logger middleware for node.js DIRECT 8 1789117062 ms • 2.0.0 Tiny milisecond conversion utility INDIRECT 0 1494937566 negotiator • 0.6.4 HTTP content negotiation INDIRECT 0 1729308043 object-inspect • 1.13.4 string representations of objects in node and the browser INDIRECT 0 1738718770 on-finished • 2.4.1 Execute a callback when a request closes, finishes, or errors INDIRECT 1 1645546248 on-headers • 1.1.0 Execute a listener when a response is about to write headers INDIRECT 0 1752766891 performance-now • 2.1.0 Implements performance.now (based on process.hrtime). INDIRECT 0 1487514529 psl • 1.15.0 Domain name parser based on the Public Suffix List INDIRECT 1 1733134564 punycode • 2.3.1 A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms. INDIRECT 0 1698690512 raw-body • 2.5.3 Get and validate the raw body of a readable stream. INDIRECT 10 1764084228 safe-buffer • 5.1.2 Safer Node.js Buffer API INDIRECT 0 1524687024 safe-buffer • 5.2.1 Safer Node.js Buffer API INDIRECT 0 1589128650 safer-buffer • 2.1.2 Modern Buffer API polyfill without footguns INDIRECT 0 1523184162 side-channel-list • 1.0.1 Store information about any JS value in a side channel, using a linked list INDIRECT 2 1775667313 side-channel-map • 1.0.1 Store information about any JS value in a side channel, using a Map INDIRECT 17 1733892798 side-channel-weakmap • 1.0.2 Store information about any JS value in a side channel. Uses WeakMap if available. INDIRECT 18 1733895551 side-channel • 1.1.1 Store information about any JS value in a side channel. Uses WeakMap if available. INDIRECT 20 1780950887 sshpk • 1.18.0 A library for finding and using SSH public keys INDIRECT 9 1697736191 statuses • 2.0.2 HTTP status utility INDIRECT 0 1749239761 toidentifier • 1.0.1 Convert a string of words to a JavaScript identifier INDIRECT 0 1636928349 type-is • 1.6.18 Infer the content-type of a request. INDIRECT 3 1556287189 unpipe • 1.0.0 Unpipe a stream from all destinations INDIRECT 0 1434313819 uuid • 3.4.0 RFC4122 (v1, v4, and v5) UUIDs INDIRECT 0 1579208738 vary • 1.1.2 Manipulate the HTTP Vary header INDIRECT 0 1506217631 verror • 1.10.0 richer JavaScript errors INDIRECT 3 1493743247 x11-hash-js • 1.0.1 x11 javascript hashing algorithm in pure javascript INDIRECT 0 1527157232